Precautions / Disclaimer

Help >

Precautions / Disclaimer

This product is very critical in a vehicles controls and could cause accidents and death or injury. Spitronics carry no responsibility in this regard as it is a DIY product that is installed by third parties. If you are an installer then read the instructions carefully and communicate the fact that it is used at your/his own risk, to the customer. Strictly abide by the wiring ruses as this may cause accidental opening. It is your responsibility as an installer and make the customer sign a disclaimer should something go wrong.

Copyright © 2013. All rights reserved.


Introduction

Help >

Introduction

The Proxima or Mercury2 can be used as throttle by wire controller. Proxima can be used for single acting throttles and Mercury2 can be used for single or dual acting throttles. Double acting throttles require positive and negative drivers to form an H-bridge. This will allow current to change direction to open or close the butterfly. Dual throttles have a rest position that is partially open to act as limp mode power during electronic failure. This product is in prototype status and use the ECU software for now. Dedicated TxW software will follow soon.

These units are standalone units and can operate without the engine running. It may also be used with other management systems. There are protection diodes and resistors wired into the system. It also has its own relay to power the throttle. These modifications is to ensure lockout of the power to the throttle during and malfunction of the sensors, harness or electronics. Do not power the unit via another source by bypassing the relay etc.


Mercury2

Help >

Introduction Mercury2

The Mercury2 can be used as throttle by wire controller. This feature will reduce the amount of inventory that a dealer has to keep for different products. Note that some of the components is not standard in the Mercury2 and was built into the harness. These are filtering diodes and voltage level resisters for protection against sensors or harness failure. Mercury2 has positive and negative drivers to form an H-bridge. This will allow current to change direction to open or close the butterfly.

The hardware class will determine features that can be activated on them.

· Standard Class - normal throttle by wire control + idle control + Cold start compensation

Read the subfolders for detail installation and setup instructions. First finish the wiring then do the setup as the sub folders are placed, top to bottom in sequence.


Firmware File Name

Help > Mercury2 >

Firmware File Name

Mercury2 TXW Standard 6 Ver 3.5B 18_04_2018.HEX

The dates may differ but Ver 3.5B if discussed here in this manual.


Step 1: Pedal TPS

Help > Proxima >

Pedal TPS

The TPS selection must be on. The electronic pedal signal is wired to this input. This input goes only to the TxW and not the ECU etc. It is an indication to the firmware what the driver requires and it could be modified in relation to actual throttle movement. This mean the pedal could be 50% depression but the actual throttle opening could be 35%.

Once wiring and connections are done you may proceed to calibration. Calibration is done as normal by stepping on the pedal and releasing it. After save is pressed the Mercury2 will do an automatic calibration of the throttle. It will open the throttle completely and take a reading. Then close it completely and take another reading. Then switch power off and take a reading of the rest position. The throttle TPS is now also calibrated but the throttle control power still needs to be setup. This is described further in the manual. If you are not sure on TPS calibration then see the ECU manual for calibration procedure.

Show graph is used for pedal profile change and discussed in another sub folder.


Step 2: Throttle TPS

Help > Proxima >

Throttle TPS

The Tuning Pot selection must be on. This is the Throttle TPS input. It will relay the actual throttle position to the TxW controller. This signal is also connected to the ECU and TCU as a TPS input. In some cases, the ECU may supply the power to the TPS, and in some it may be the TxW that supply the power of 5 volts. Do not connect both supplies together as it may damage some of the devices, one system must tap in. Note that systems that share sensors requires the same earth connection to ensure signal accuracy.

The Tuning Pot input must be selected on launch. The pot register is the Dashpot damper in % throttle opening. When the throttle is blipped it will dampen the return to let the engine return to idle more gradually. This is very useful with automatic transmissions to prevent stalling. If the Pedal TPS value is greater than TPS idle cutoff, and revs is 500 rpm more than target RPM, then the throttle minimum opening is set to this %. When the pedal is release below TPS idle cutoff, then the throttle will be momentarily stopped at this opening and then returned slowly. Start with a small value and blip the throttle. See the effect of dampening at a slighter higher than idle RPM.


Step 3: Throttle Setup

Help > Mercury2 >

Throttle Setup.

The throttle limits is calculated by the Mercury2 during pedal TPS calibration. This process will determine opening and closing power to control the throttle gently. It differs between different throttle manufacturers and must be adjusted for each type. If you load a map from a similar throttle then it should be working.

The accelerator pump in the ECU software is used for the throttle adjustments. Note that the text in Red is not in the software but only for explanation which blocks to adjust.

To adjust these values first zero all four of them. The throttle will then have no power on it and it should show the resting %.

This Pot value multiplied by 2.55 should be roughly the same as the Map Teeth value. This is handy to know later if you want to fine tune erratic movement around the rest position.

Map Teeth is the rest position of the throttle and is a value from 0 to 255 which represent 0 to 100% throttle. Map Teeth = POT * 2.55

To adjust throttle opening duty and gain.

Put the ignition on. Do not start the engine.

Put the TPS graph, Water Temperature and Idle-control off. Also put low limit duty cycle to 0.

Calibrate of the TPS if you have not done it yet. When you save after Pedal TPS calibration, the ECU will open and close the throttle automatically and then leave it in rest position. The Software will refresh the display the new Map teeth value.

Now press and keep the throttle in completely. Look at the throttle TPS in the real time screen on the POT bar. Now use the arrows of Opening Duty and increase the value till the throttle open above 95%. Remember this value. Now reduce the value till the throttle close to 5% above the rest position (less than 9 + 5 =14%) Take the average of the two values and set opening duty to that value. In this example 115(to open) + 75(to close) = 190 / 2 = 95. Now release the throttle. If you press it again, the throttle should not open.

Now release the throttle and increase the Closing Duty till the throttle close to 1 or 2 %. Then lower the Closing Duty till the throttle open to 8 %. Take the average of the two values and set closing duty to that value. It should be similar than the opening duty.

Now press the pedal fully and increase the Opening gain slightly. The throttle should open to about 99%. You may increase the value till you get a fast enough response and the throttle follow the pedal value. If the gain value is too high the throttle will vibrate. It should be around 4.

Now release the pedal and increase the Closing Gain till the throttle is about 1% value. The closing values should be the same value as the opening duty and gain.

Now press the pedal slowly so that the throttle read the same as rest point. Take it slowly above the rest point and back. Notice if the throttle shudder excessively on the transition point. If it does increase or decrease the map teeth and see where the throttle is smooth when it pass the rest point with the least amount of shutter. Save the settings to the device.

This value is the minimum opening that the TxW will control the butterfly. Now you may start the engine and adjust the Low Limit Duty Cycle till the engine idles on its own. Let the engine get up to working temperature and adjust this setting till the engine runs at the desired idle RPM minus 100. This will allow the TxW to control the idle faster. You may now proceed to idle control setup..


Step 4: Throttle Modulation

Help > Proxima >

Throttle Modulation

The throttle movement can be adjusted to open on a different value than the pedal set point. This is handy when large throttles are used. Then when it is used in town you can select more pedal movement than throttle movement which will make the car more drivable or the pedal less sensitive. Then on last movement to full throttle the throttle will move more than the pedal and give the extra power required.

Selected the Show Graph next the TPS selection.

See picture below. The X Axis is pedal TPS movement and the Y axis is throttle movement set point. The range is from 0 to 100. -50 is 0% and +50 is 100% throttle. If Show Graph is off then throttle movement set point will be the same as pedal TPS %.

After setting make sure the throttle can move over the whole scale range. Note that Low Limit Duty Cycle will cause the throttle to not go to 0% but remain it idle %. You may start the graph at a higher value that -50% so that the throttle moves more instantly when the pedal is pressed. Make sure not to make it too high as it will then overcome the min duty cycle.


Step 5: Cold Start Compensation

Help > Proxima >

Cold Start Compensation

The TxW can do cold start compensation. It compensates by increasing the min opening of the throttle. It is more stable than to lift the target RPM's. It will operate also if idle control is not used.

To use cold start control, the unit requires a water temp sensor. This system has 2 options. A standalone sensor and a tap in input for the Spitronics ECU's. Note that the curve for both sensors is for the 2K NTC resistors. The tap in wire does not have a pull-up resistor and will not influence the ECU reading.

For the pull up resistor option on water sensor for standalone systems, set the water and air sensor as below. Put water calibration value on 100. The water sensor input on the mercury2 is used. The water compensation graph will replace the Low Limit Duty Cycle value as idle setting. See further in the manual.

For the tap-in option with no pull up resistor, set the water and air sensor as below. The Lambda sensor input on the mercury2 is used for the tap-in input as it has no pull-up resistor. Put water calibration value on 100. Air calibration is not used as a sensor merely as a selection. The water compensation graph will replace the Low Limit Duty Cycle value as idle setting. See further in the manual.

If both settings are off, then there will be no water temperature compensation for cold start. The Low Limit Duty Cycle value will be used as idle setting when no temperature sensors is selected.

With temperature compensation selected, the water graph for fuel will be used as the minimum closing duty cycle with temperature compensation. Note that the graph is used from 0 to 100 which means 0% to 100% opening. For a cold engine you can raise the value which will let in more air to compensate for poor fuel burn. This feature can also be used without idle control. See the graph below.


Step 5: Idle Control

Help > Proxima >

Idle Control

To use idle control the unit requires an RPM pulse. Any number of pulses per revolution could be used up to 60. This will calibrate the rev counter in the software easily. You may compare it to the ECU RPM counter. Ex. Should you use a 36-2 trigger wheel then select 34 pulses.

The Pulses/RPM block is used for this value.

The rest of the idle control settings is the same as is used in the ECU. See description below.

Idle Control Type

If idle control is used then select Idle Valve. Otherwise select Not Used. If idle valve is selected then the RPM signal will become active. Otherwise it is disabled.

RPM

This setting is the target idle RPM's when the engine is on running temperature. Note that the min idle setting or the cold temperature compensation may cause the engine to idle at a higher value.

Start %

This setting is used to increase the air intake when the engine is started hot or cold. The ECU will open the idle valve to this %. Once the engine reaches 500 RPM it will cancel this setting and go to normal throttle operation. If you press the pedal then this setting will be override.

Response Time Up

This setting will determine the rate at which the valve opens when the actual RPM's fall below the set point in Idle RPM. The further the RPM fall below the set point, the faster the ECU will open the valve to let in more air. Low values will create a faster response time and high values will create a slower response time. This setting must prevent the engine from stalling when you switch the air conditioner on, or put it in drive.

Response Time Down

This setting will determine the rate at which the valve closes when the actual RPM's go above the set point in Idle RPM. The further the RPM goes above the set point, the faster the ECU will close the valve to decrease airflow into the engine. This value is set higher than the Response Up value, to eliminate hunting. Low values will create a faster response time and high values will create a slower response time. This setting must bring fast idling down as fast as possible without hunting the engine.

Low Limit duty cycle

This setting will preload the TxW so that the valve does not close beyond this value. It is used as min idle when there is no temperature sensor connected. To set the value start with a larger % and decrease until the desired idling RPM is reached in neutral when the engine is on working temperature. Note that the throttle modulation or cold start compensation may override this value.

High Limit duty cycle

This setting is used to limit the maximum throttle opening. It is set at 100 to open the throttle fully. It may be used as power limiter by entering lower values.

TPS Idle Cutoff %

This value is used to disable the idle control when the driver touches the throttle. The reason is that the ECU must know when not to control idle as the driver may need just a minimal amount of revs with slight throttle.


Limp Mode Testing

Help > Proxima >

Limp Mode testing

It is good practice to test the TxW for sensor failure. Any one of the 3 wires of the two TPS sensors can fail and then the TxW must react and put itself in limp mode. To test this operation lightly connect the 2 TPS sensors. After throttle setup, put the ignition on and press the pedal 50%. The throttle will open some way depending on setting. Now take the 6 wires to the 2 TPS sensors off only one at a time. Each time the throttle must fall out and go in limp mode. Limp mode means the butterfly is in rest position. If it goes fully open or fully close, then there is a wiring problem. Some single action throttle may close completely. After fixing the problem then solder the joints and cover them properly. Remember this throttle control the power of the engine and it could cause the car leaping forward and into an accident or leaving the road. So make sure wiring is done according to recommendations.


Trouble Shooting

Help > Proxima >

Trouble shooting

There are common problems that installer make that hinder proper operation and reliability. Especially if custom harnesses are made. Below are a few examples:

  • Make sure the TxW earth and ECU earth is mounted on a proper place on the body of the car. Do not make long earth leads to the battery. See the power wiring section in the ECU manual.
  • The power on the relay pin 30 must come from the battery and thick wires. Do cot connect pin 87 to the ECU relays.
  • If the power wires are too thin then the throttle calibrations change once you start the engine. This may also be due to the alternator wiring that connects with the power harness.
  • The ECU power comes from the key power circuit and not the same power that supply the throttle. This usually make interference in the RPM signal.
  • Make sure the RPM signal is constant and stable. Erratic behavior will result in incorrect idle control.
  • The free-wheel diodes must also have a proper earth and power wire. Earth must go to the ECU earth point and positive to pin 87.
  • Do calibration and setup in the same order as discussed in the manual. Make sure the throttle flap open, close and rest after you calibrated pedal TPS.
  • If you set up the system and it does not perform like the document say investigate or contact your dealer for support. Do not let something halfway into the street.
  • Make sure you wire the resistors in as the harness drawing suggest. The reason is that it is fail safe resistors in case a wire break off. See the Limp Mode Testing section.
  • Throttle is hunting on idle control. Make sure the ECU settings on idle fuel and timing settings is correct. See the idle control tuning section. It could also be incorrect settings of gain and rest position.


Wiring

Help > Mercury2 >

Wiring

See the wiring diagrams in the sub folders for each type of throttle valve. There may also be custom firmware for different models like the Citroen TxW. Make sure to connect the free wheel diodes correctly and let the Mercury2 power its own relay as per drawing. Note that the dual throttle requires 4 diodes to eliminate spikes. After the unit is tuned you may load the lock file which means the firmware does not have the ability to write to memory during interference spikes on the micro. If you need to make adjustment reload the normal firmware.

Basic universal drawing

Mercury2 Reference Wiring Diagram

Specific models drawings

Mercury2 Lexus 3UZ Wiring Diagram

Mercury2 Citroen Wiring Diagram

Harness design drawings

X05 Harness

X06 Harness


Proxima

Help >

Introduction Proxima

The Proxima is a dedicated throttle by wire controller. It is based on Pluto2 electronics with a few hardware modifications for filtering diodes and voltage level resisters. The harness does not require electronic components. Proxima has only negative drivers which will allow current in one direction only. It can only be used on single action throttle which can only open throttles that don't have limp mode rest positions.

The hardware class will determine features that can be activated on them.

· Basic Class - normal throttle by wire control + idle control

· Standard Class - normal throttle by wire control + idle control + Cold start compensation

Read the subfolders for detail installation and setup instructions. First finish the wiring then do the setup as the sub folders are placed, top to bottom in sequence.


Firmware File Name

Help > Proxima >

Firmware File Name Proxima

Proxima TXW ECU Combo 1 Ver 3.5B 18_04_2018.HEX

The dates may differ but Ver 3.5B if discussed here in this manual. This firmware is written to use the same settings as the Mercury2 firmware, to minimise confusion. Ver 3.5 uses different blocks in the ECU software. Pluto2 is featured on the information because we use this software till the dedicated throttle by wire software is commissioned.


Step 3: Throttle Setup

Help > Proxima >

Throttle Setup Proxima.

The throttle limits is calculated by the Proxima during pedal TPS calibration. This process will determine opening and closing power to control the throttle gently. It differs between different throttle manufacturers and must be adjusted for each type. If you load a map from a similar throttle then it should be working.

The MAP accelerator pump in the ECU software is used for the throttle adjustments. Note that the text in Red is not in the software but only for explanation which blocks to adjust.

To adjust these values first zero all both of them. The throttle will then have no power on it and it should show the resting 0%.

To adjust throttle opening duty and gain.

Put the ignition on. Do not start the engine.

Put the TPS graph, Water Temperature and Idle-control off. Also put low limit duty cycle to 0.

Calibrate of the TPS if you have not done it yet. When you save after Pedal TPS calibration, the ECU will open and close the throttle automatically.

Now press and keep the throttle in completely. Look at the throttle TPS in the real time screen on the POT bar. Now use the arrows of Opening Duty and increase the value till the throttle open above 95%. Remember this value. Now reduce the value till the throttle close to below 5%. Take the average of the two values and set opening duty to that value. In this example 115(to open) + 75(to close) = 190 / 2 = 95. Now release the throttle. If you press it again, the throttle should not open.

Now press the pedal fully and increase the Opening gain slightly. The throttle should open to about 99%. You may increase the value till you get a fast enough response and the throttle follow the pedal value. If the gain value is too high the throttle will vibrate. It should be around 4. Save the settings to the device.

This value is the minimum opening that the TxW will control the butterfly. Now you may start the engine and adjust the Low Limit Duty Cycle till the engine idles on its own. Let the engine get up to working temperature and adjust this setting till the engine runs at the desired idle RPM minus 100. This will allow the TxW to control the idle faster. You may now proceed to idle control setup.


Wiring

Help > Proxima >

Wiring Proxima

See the wiring diagrams in the sub folders for each type of throttle valve. There may also be custom firmware for different models like the Citroen TxW. Make sure to connect the free wheel diodes correctly and let the Proxima power its own relay as per drawing. After the unit is tuned you may load the lock file which means the firmware does not have the ability to write to memory during interference spikes on the micro. If you need to make adjustment reload the normal firmware. You will need a Firmware Programmer for this option.

Basic universal drawing

X03 Reference Wiring Diagram.pdf

X04 Reference Wiring Diagram.pdf

Specific models drawings

Lexus 1UZ Wiring Diagram.pdf

Lexus 2UZ Wiring Diagram.pdf

Harness design drawings

X03 Harness.pdf

X04 Harness.pdf


ECU Idle Control Tuning

Help >

Idle control Tuning

Idle control is done with different methods. It could be external idle valve or stepper motor or it could be done with partial throttle motor or full drive by wire throttle. Due to the delay in mechanical control to stabilise idle, you need to tune the ECU and idle valve together. The reason is that the ECU can react faster than a mechanical air restrictor valve. And most of the times hunting is a result of incorrect engine tuning. If idle drops then the valve opens to correct. That adds more air resulting in a worst effect and it comes with a delay. Then the ECU will add fuel due to more air resulting in high rpm which in turn close the idle valve and this repeats out of control. Also after blip the idle valve must capture the engine rpm before it stalls. Again here the ECU can react faster by adding timing and fuel to assist in this process. This section describe what needs to be done on the ECU side to help smooth idle control. See the different types of idle control and how to adjust their settings in the idle control setup section.

Setting the Idle Jet for Time & Fuel

When an engine idles in neutral and is at working temperature, the idle timing should be around 15 to 18 degrees depending on altitude. This may vary from engines but this is a basic guideline. Increasing idling degrees usually result in higher RPM's. Do not confuse this thinking it is what the engine needs. All you will do is lowering the air volume to bring idle down. This will result in very poor power and engine will easily die off when you put a bit of load on it. The lower the engine timing the slower the engine idles and the more idle air it requires. It will also require a slightly richer mixture. Now if you put a little load on the engine you immediately add timing which will make more power due to the rich mixture with more air. Adjusting timing is immediate and there is no mechanical delay. Now when an engine wants to hunt you can effectively control power to it without the idle control valve or throttle movement. Below is some basic ECU settings.

First adjust the timing so that at idle there is 15 degree dynamic timing and no vacuum timing.

Adjust the Idle fuel so that the engine has just enough fuel to idle constant. Do not make it too rich. It should be close to avalanche point where if you go leaner the engine will lose power. The best way to see this point is where the vacuum signal will be at its lowest point for normal engines. Any more or less fuel will results in higher vacuum. Racing cams and matrix tuning will be saver to look at A/F ratio. Idling RPM's should be on your Target RPM value. In this example 800 RPM. Notice that the green and brown graph below on RPM compensation is at zero compensation. Only the main graph determine idle fuel. Also make sure water and air compensation is zer0.

Now when the engine hunts we will use timing to control it before the idle valve needs to act. First you must understand what happens in hunting. The engine will lose power resulting in an increase in manifold vacuum. The vacuum bar will move to the right and the RPM bar will move to the left. Due to our slower timing we can increase timing to add power which will increase RPM. Adjust the Low rpm timing graph as below.

Lower rpm also brings more air in the manifold which requires a bit more fuel to make the mixture a power mix. Adjust the green and brown graph on the RPM graph ay the lower rpm range to add a certain % fuel. Note on the fuel load graph we already should have a slight increase in fuel.

Now the above adjustments will capture falling RPM's and it may now cause the idle control valve to react as well adding air. This will increase RPM above target. There is an up and down response on the idle valve control settings. As a rule we make up response faster to ensure that the engine does not stall. Then we make down response slower to prevent hunting. Will result in more vacuum which makes the vacuum bar move left and the RPM bar moving right. First we use timing again to make it slower reducing engine power.

Then less air also needs less fuel. This time we adjust the fuel load graph as the engine don't use this part for normal riding. Note however, that deceleration will cause the vacuum to move in this region. If the mixture is too lean then the engine to being jerking due to too lean mixture.

Automatic Transmissions

For automatic transmissions tuning principles are the same as above. But there are two load steps that differs for neutral and drive. After you do the neutral tuning, then put the engine in drive. The load on the engine from the transmission will cause the vacuum bar to move to the right quite a bit. RPM is controlled and will stay the same. So you need to make sure that the idle fuel will increase for the added load.

Related Links

Idle Control Wiring

Idle Control Setup

Error Codes


Idle Control

Spitronics ECU's has the capabilities to do idle control. There are 2 main types of idle control motors namely; valve and stepper motor controllers. The new generation engines use the throttle by wire to do idle control. See the TxW manual for its explanation. It is not covered in this manual as it is a Spitronics standalone product.

(For more information, see sub folders.)

Related Links

Software

Idle Control Tuning


Error Codes

The ECU software has Error, Warning and Information codes displayed in the Status tool bar at the bottom. These codes will help the tuner to find problems during startup and tuning, also to see if the ECU is functioning correctly. Some of the functions on the ECU will indicate to the tuner what is happening. He can then see if these functions are operating correctly.

The codes are displayed at the right hand bottom corner. The code list [image] will display a list of accumulating codes so that the tuner can see what the codes were and in which order. The bottom indication will only show the last code. Also note that a code is only updated once, until it disappears and when it appears again the code will be logged again. This is to prevent the list from being too long. This does not apply to the angle sensor error codes during cranking. They will increment the counter as each one occurs.

Press the ''C'' key to clear the error codes. This is handy as you will not be able to see is the code is still present or if it was only listed once.

Note: If you crank an engine and it does not start, there will be one error code, error code 6 for Emergency Engine Shutdown. This is normal and not an actually an error. The ECU was expecting more trigger pulses but pulses were stopped. Therefore, the ECU goes into a safe shutdown of coils and injectors etc. A tip, press C then crank the engine. There should be no error and it will read 200 RPM's on the rev counter until the key is released.

The blue codes are for crank and cam related sensor errors. This is normally the angle signals that makes the ECU operate correctly. The red codes are warnings like over temperature etc. The green codes are for information of functions that were activated. The colors are only for explanation in this document.

The following list explain the different error codes

1 - Missing crank pulses - The crank sensor senses too little teeth per revolution

2 - Too many crank pulses or spikes - The crank sensor senses too many teeth per revolution

3 - Incorrect crank TDC slot - The crank sensor did not sense a TDC slot. (Maybe incorrect wiring)

4 - Missing TDC pulse - The TDC pulse is not present

5 - Missing home pulse - The Home pulse is not present

6 - Emergency engine shutdown - Safe shutdown of engine due to lack of or incorrect signals

7 - Fuel pressure safety cut-out - The fuel pressure sensor low limit has been reached

8 - Economy fuel cut-out - The fuel economy cut is implemented

9 - RPM limiter reached - The engine RPM limiter has been exceeded

10 - Max boost limiter reached - The boost pressure limit has been exceeded

11 - Water hot/cold temperature limiter reached - The water temperature limit has been exceeded

12 - Launch limiter reached - The launch limit RPM has been exceeded

13 - Lambda control limits reached - The lambda control limit has been reached

14 - Battery low voltage limit reached - The battery voltage falls below a critical limit

15 - Selection refreshed. Confirm driver placement - The ECU changed driver output configurations

16 - Timing retarded - Ignition timing is retarded during an automatic transmission shift procedure

17 - Flood control injector cut-out - Fuel is cut by injectors during cranking when the throttle is fully opened

18 - Flat-shift activated - Ignition or fuel is cut for a moment to enhance gearshift for racing engines

19 - Ignition power switched off - Ignition key power is switched off

20 - Sponsor counter depleted - The sponsor counter is depleted for sponsored ECU's

21 - Anti-Lag activated - Anti-Lag is activated on the Launch features


Idle Control

The ECU has the feature to control different types of idle motors found on an engine. Before adjusting the idle control settings, you need to select which type of valve or stepper is on the engine. Note: The stepper types idle motor (4 to 6 wire), require the external electronic driver. Also note that the electronic unit differs between the 4 Wire bipolar type motor and the 6 Wire common supply type motor.

Type Selection

The Type Selection can select between the two-wire spring-loaded Idle Valve, the three-wire spring or non-spring loaded Dual idle valve, the Bipolar Stepper motor or common supply Stepper motor. Stepper motors do not use the Low Limit and High Limit settings as they keep their position when there is no signal present. If there is no idle control select 'Not' used to free up valuable processor time and general purpose outputs.

Idle Valve

Two wire spring loaded idle valve only use one output from the ECU.

Dual Idle Valve

Three spring or non-spring loaded idle valve two outputs from the ECU.

Stepper Motor

Four or Six wire idle valves operate with a Spitronics Type 1 or Type 2 stepper motor controller, use one output from the ECU.

Settings

Drivers

This indication will show the installer which wires to connect on which outputs of the ECU. Driver 2 is only used for the dual valve to close. Note that positive and negative drivers may be used for idle control. If a valve is used, then make sure the Diode across it is wired correctly. (See the wiring diagrams and general purpose priority spreadsheet for correct installation.)

RPM

This setting is the target RPM's when the engine is on running temperature. When it is cold the ECU will automatically increase engine RPM's with up to 300 RPM's. This is calculated according to fuel enrichment on the water compensation map. Every 15% will increase 100 RPM on the Idle control.

Start %

This setting is used to increase the air intake when the engine is started hot or cold. The ECU will open the idle valve with this %. Note that on stepper controls it will activate 25% every time the key is switched on. If you don't start it, it may idle high at first then come back to idle target.

Response Time Up

This setting will determine the rate at which the valve opens when the actual RPM's fall below the set point in Idle RPM. The further the RPM fall below the set point, the faster the ECU will open the valve to let in more air. Low values will create a faster response time and high values will create a slower response time. This setting must prevent the engine from stalling when you switch the air conditioner on, or put it in drive.

Response Time Down

This setting will determine the rate at which the valve closes when the actual RPM's go above the set point in Idle RPM. The further the RPM goes above the set point, the faster the ECU will close the valve to decrease airflow into the engine. This value is set higher than the Response Up value, to eliminate hunting. Low values will create a faster response time and high values will create a slower response time. This setting must bring fast idling down as fast as possible without hunting the engine.

Low Limit duty cycle

This setting will preload the solenoid against the spring in the idle valve so that the valve starts to open immediately when the ECU starts increasing the value. It can also be used to set minimum idling RPM for throttle valves that closes completely. To set the value start with a larger % and decrease until the desired idling RPM is reached.

High Limit duty cycle

This setting is used to limit the maximum idle RPM's. No need to open the valve more than necessary. It also allows for the use of large valves in smaller engines. Make sure that when the engine is cold, it can still lift the RPM up to approx. 1500 RPM. This can be tested by entering a large Idle RPM value and limit the ECU from increasing it too high.

TPS Idle Cutoff %

This value is used to disable the idle control when the driver touches the throttle. The reason is that the ECU must know when not to control idle as the driver may need just a minimal amount of revs with slight throttle.

Related Links

Idle Control Wiring

Idle Control Tuning

Error Codes